0 Пользователей и 1 Гость просматривают эту тему.

*

stolbik83

Проблемы с изображением в 3D-окне.
« : Января 07, 2007, 22:07:36 »
Всем здрасте.
При построении 3d-проекции в ArchiCad-10 получается корявое изображение: линии ломанные, просвечивают там, где не должны, или лишние, где должно быть пусто. Перекрытия, стены и т.п. исчезают. В общем, полный бардак. При передвижении в 3d ничего не понятно - все искажено. При построении фото - все нормально.
В чем глюк? Из-за перегруженности Объектами (хотя их количество в пределах разумного), видеокарте, настройках программы или что-то другое?
Абсолютно невозможно ориентироваться (((
Заранее спс!

*

Оффлайн crazyASD

  • Самый главный
  • *****
  • 8339
  • Репутация: +504/-24
  • Пол: Мужской
  • iCrazy
Re: Проблемы с изображением в 3D-окне.
« Ответ #1 : Января 08, 2007, 02:36:42 »
Может быть что угодно, начиная от того, какой ты режим ты использешь Internal или OpenGL, Какая у тебя видеократа, правильный ли DirectX, кривые или прямые драйвера... и.т.д
Пробуй...

*

Оффлайн IgorK

  • *****
  • 669
  • Репутация: +32/-1
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #2 : Января 08, 2007, 10:40:09 »
Может прозрачность слоёв включена?

*

Оффлайн Acid

  • **
  • 40
  • Репутация: +0/-0
Re: Проблемы с изображением в 3D-окне.
« Ответ #3 : Января 08, 2007, 16:16:50 »
нет, не в прозрачности дело. У меня тоже некоторые объекты, стены, перектрытия и т.п. становятся прозрачными, даже если у них ее абсолютно нет.

с дровами все в порядке, директ Х тоже в норме. Режим Open_GL.

Но проблема незначительная, ориентироваться (мне лично) легко, с места ничего не убегает, только некотрые объекты, которые ближе к \"камере\" определенного значения N становятся прозрачными, причем это N в разных направлениях разное, от 1-2 метра в сторону по оси Y в \"+\" и до 8-10 метров в строну по оси Y в \"-\". Так же при узменении угла наклона камеры расстояние до прозрачной границы разное. (Если смотреть под большим углом вверх или вниз, то вертикальные объекты становятся прозрачными дальше, если смотреть почти горизонтально, то горизонтальные объекты вблизи камеры пропадают.)
Надеюсь понятино объяснил :whistle:

При использовании внутреннего механизма построения таких глюков не возникает.

 

Post edited by: Acid, at: 2007/01/08 16:21

*

Оффлайн Valery W

  • *****
  • 5987
  • Репутация: +629/-14
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #4 : Января 08, 2007, 17:05:06 »
Такое впечатление будто включен 3D-разрез.

А как определил, что с драйверами все в порядке?
И действительно, а какая видеокарта?
А смотрел ли тесты по своей видеокарте на _http://archicad-talk.graphisoft.com ?

Я наблюдал такую картину:
1. стандартный драйвер - плохая работа в 3D-окне АС9 и нормальная в АС10.
2. обновил драйвер - нормальная работа в АС9 и плохая в АС10
3. следующее обновление драйверов - вообще не возможно работать в АС9 и отлично в АС10.
Все эти наблюдения относятся к режиму OpenGL.

*

Оффлайн GAG

  • *****
  • 940
  • Репутация: +129/-1
  • Пол: Мужской
  • GAG
Re: Проблемы с изображением в 3D-окне.
« Ответ #5 : Января 08, 2007, 19:41:33 »
классический случай на видюхах от нвидиа, всртечается только с родными драйверами, т.е. если у вас есть карта серии 5ххх и к ней есть стандартный майкрософтовский драйвер, поставляемый с Win XP SP2, то подобного глюка в OpenGL не будет. лично проверял несколько раз на нескольких компах на работе. после того, как мне обновил и комп и вместо старой 5600 поставили 6600, то вернуться к MS дровам нет возможности.
единственная причина, по которой нужны родные дрова от nvidia - это OpenGL игры типа Quake3

ещё иногда бывает так, что слетает перспектива, дистанция камеры/высота устанавливаются в неприемлемые значения

кстати, у нас было так, что один проект бродился в 3D без проблем, а другой, на этом же компе, глючит.

*

Оффлайн Acid

  • **
  • 40
  • Репутация: +0/-0
Re: Проблемы с изображением в 3D-окне.
« Ответ #6 : Января 08, 2007, 22:55:31 »
видюха NVidia 6600 GT.
дрова поставляемые с оборудованием и которые в винде XP Full Final. Разницы нет.

А то, что в разных проектах на одном и том же копме этот глюк бывает разным, иногда его вообще нет.

Может не в дровах дело? И какая разница дровам в каком проекте бродить? По одному зданию ходят, а по другому нет:dry:

А еще: только что заметил, на разрезе появилась пара точек (причем коричневого цвета, а я обычно ставлю красные или ярко-голубые), в свойствах которых указано, что они принадлежат этажу 15011:woohoo: Удалял минут 15, а они не заканчивались. Их там наверно и вправду 15 тысяч...
 

Post edited by: Acid, at: 2007/01/08 23:00

Post edited by: Acid, at: 2007/01/08 23:05

*

Оффлайн Valery W

  • *****
  • 5987
  • Репутация: +629/-14
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #7 : Января 09, 2007, 01:20:56 »
Возникла мысль относительно вопроса stolbik83.
Может у тебя дубликаты на одном этаже? Или теже элементы на верхнем этаже налезают или совпадают с элементами нижнего. Проверь.

По вопросу о точках на разрезе у Acid.
На разрезах у конструктивных элементов всплывающее инфоменю показывает этаж на котором установлен элемент. А у 2D-элементов оно показывает этаж больше 15000. Чего то разработчики не доработали.
А узловая точка, скорее всего, у тебя одна. И она так и осталась не удаленная. Она совпала с точкой начала проектной или пользовательской системы координат, и не выделяется щелчком. Еще одна недоработка разработчиков.
Выдели узловую точку рамкой и удали.

*

Оффлайн Acid

  • **
  • 40
  • Репутация: +0/-0
Re: Проблемы с изображением в 3D-окне.
« Ответ #8 : Января 09, 2007, 03:07:30 »
неа, с началами координат не совпадает, проверил.

со временем таких точек становилось все больше и больше, закономерность их появления не установлена (появлялись даже на пустых местах). Метод построения разреза \"Визуализация\", там 2D элементов быть не должно.
Как говорилось к каком-то фильме: \"Не обращайте внимания, это глюк\".

*

Оффлайн Int

  • *****
  • 3699
  • Репутация: +364/-5
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #9 : Января 09, 2007, 11:49:55 »
проверил на GeForce 6600GT со стандартных древними дровами(идущими с поставкой), DirectX 9.0.c

тестил на одних и тех же объектах

AC9 - никаких глюков - летает, особенно если вертеть
зацикленно по оси :D

AC10 - глюков тож, вроде, не замечено, но повертеть, как в девятке вокруг оси уже не получается, вместо это там orbit плин ) поэтому отловить где быстрее не вышло, но по ощущениям, AC10 немного проигрывает в быстроте прорисовки.


вот.

*

Оффлайн Valery W

  • *****
  • 5987
  • Репутация: +629/-14
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #10 : Января 09, 2007, 12:30:58 »
Не должен АС10 проигрывать в скорости.

Активируй панель "Классическая 3D навигация" и будешь крутить как в АС9.
« Последнее редактирование: Ноября 20, 2007, 20:06:50 от Valery W »

*

Оффлайн crazyASD

  • Самый главный
  • *****
  • 8339
  • Репутация: +504/-24
  • Пол: Мужской
  • iCrazy
Re: Проблемы с изображением в 3D-окне.
« Ответ #11 : Января 09, 2007, 12:47:59 »
Я сейчас делаю проект МЖК для института, видяха GF5600 256mb - Тормозит жутко (в здании, вернее в нескольких, около тысячи окон и столько-же дверей) думал проблема в драйверах, поставил свежатину - один фиг, как тормозило так и тормозит, причем как в 3D, так и 2D, - попробовал отключить аппаратное ускорение OpenGL, и О ЧУДО! тормозить стало меньше и быстрее стало строить 3D проекции!
Создается впечатление, что моя видеокарта попросту игнорируется движком OpenGL в ArchiCAD!!!
Решение проблемы (Отчасти решение), нашел включив фильтр отображения окон в 3D окне....
ЗЫ. Попробовал перейти обратно в 9ку.... ... там тормозило еще сильнее....
Вот такие пироги :S

*

Оффлайн Int

  • *****
  • 3699
  • Репутация: +364/-5
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #12 : Января 10, 2007, 00:02:39 »
Valery W писал(а):
Цитировать
Не должен АС10 проигрывать в скорости.
Активируй панель \"Классическая 3D навигация\" и будешь крутить как в АС9.


аа, живо оказывается.
понапрятали, заразы)))
думаю уже убрали навсегда

потестю - завтра скажу

*

Оффлайн Acid

  • **
  • 40
  • Репутация: +0/-0
Re: Проблемы с изображением в 3D-окне.
« Ответ #13 : Января 10, 2007, 02:56:59 »
проверил, дрова не виноваты (по крайней мере в моем случае).
Перенес проект в новый файл, т.е. попросту создал новый проект и скопировал поочередно все объекты по этажам из старого проекта в новый. Глюков пока что не возникает, в 3Д проекции тоже свободно перемещаюсь безо всяких искажений и прозрачных стен.

*

Оффлайн Int

  • *****
  • 3699
  • Репутация: +364/-5
  • Пол: Мужской
Re: Проблемы с изображением в 3D-окне.
« Ответ #14 : Января 10, 2007, 15:02:23 »
я тож проверил - в AC10 все летает не хуже, чем в 9:)
никаких вышеперечисленных глюков, слава богу, нету...

 

Похожие темы

  Тема / Автор