0 Пользователей и 1 Гость просматривают эту тему.

*

dejavu

Проблемы с зонами в АС9
« : Августа 02, 2005, 00:20:58 »
Ситуация такая: работаю себе спокойно, но как только в процессе работы назначаю 2-3 зоны, Архикад замирает и.... багрепортер. Стоит 9-ка с руссификацией.
Как это вылечить? В чем беда?
Иногда еще бывает библиотеки новые прикручу и ему плохо становится...
Спасайте :)

*

Оффлайн Анжела

  • ****
  • 335
  • Репутация: +16/-0
Re: Проблемы с зонами в АС9
« Ответ #1 : Августа 03, 2005, 00:14:43 »
Мне помогла замена шрифта.  У меня по умолчанию стоял "Gost type А" заменила на "Arial" и все стало нормально...
И еще, у меня в библиотеках оказалось несколько паспортов зон с одинаковым именем. Все поудаляла, оставила только один паспорт.
Удачи!
« Последнее редактирование: Декабря 11, 2007, 21:57:31 от Valery W »

*

dejavu

Re: Проблемы с зонами в АС9
« Ответ #2 : Августа 03, 2005, 03:04:49 »
2 Anjela

Вот спасибо - теперь вроде все ОК!!!

*

DDOG

Re: Проблемы с зонами в АС9
« Ответ #3 : Августа 04, 2005, 19:04:30 »
У меня все дело действительно в шрифте было. Спасибо за совет!

*

dejavu

Re: Проблемы с зонами в АС9
« Ответ #4 : Августа 05, 2005, 10:40:30 »
2 Anjela
Блин..а можно уточнить какие паспорта были продублированы? У меня вроде с паспортами ОК, но снова слетает прога :angry:
Может вообще убить все ГОСТовские паспорта?

*

Оффлайн Анжела

  • ****
  • 335
  • Репутация: +16/-0
Re: Проблемы с зонами в АС9
« Ответ #5 : Августа 06, 2005, 01:05:55 »
"Паспорт_зоны_01" их оказалось несколько в моих библиотеках.
Удачи!
« Последнее редактирование: Декабря 11, 2007, 21:58:00 от Valery W »

*

Оффлайн nideKer

  • *****
  • 2597
  • Репутация: +121/-2
  • Пол: Мужской
  • freeRide 4ever
Re: Проблемы с зонами в АС9
« Ответ #6 : Октября 27, 2005, 00:35:24 »
Была аналогичная проблема - вылечил следующим образом - грабанул арчикадовскую ветку реестра... как ни странно в моем случае помогло.
(HKEY_CURRENT_USER/Software/Graphisoft/...ArchiCAD/)

Долбался по решению проблемы долго - а тема была такая - стоит два компа - с одинаковой конфигурацией и виндой - библы грузятся с сервера - (т.е.  тоже одинаковые) на одном компе все гуд, а на втором вышеописанный вылет. Ну проба (радикальная 8) увенчалась успехом
(кста - в зонах по умолчанию стоял именно GOST type A и шрифт этот был установлен...)

Мож кому поможет...
« Последнее редактирование: Декабря 11, 2007, 21:56:22 от Valery W »

*

Оффлайн Mamon99

  • *
  • 15
  • Репутация: +1/-0
  • Пол: Мужской
  • Вот так вот!!!
Re: Проблемы с зонами в АС9
« Ответ #7 : Февраля 17, 2006, 14:22:55 »
Грабануть ветку не помогает. Изменение шрифта тоже. Удалил все зоны - оставил одну. Не помогло. После установки зоны добавляется "Кирилистический" - и так до посинения.
 В принципе зоны устанавливаются, но сохранённый файл потом не открывается. Арчик вылетает в винду с бугрепортером. Даже при полность удалённых библиотеках файл не грузится.
 Кто знает решение проблемы?
 Кстати: когда стояли зоны только 1 этажа было всё нормально, но при установке зоны на 2 этаже - смотри выше...
« Последнее редактирование: Апреля 09, 2008, 01:56:48 от CrazyASD »

*

archiDAN

Re: Проблемы с зонами в АС9
« Ответ #8 : Апреля 20, 2006, 01:32:56 »
Нашел в чем проблема если открыть Параметр зоны по умолчанию в разделе Паспорт зоны и посмотреть на тип шрифта то можно увидеть такую картину:
Arial
[Arial кириллический]
[Arial кириллический кириллический]
....
[Arial кириллический кириллический...кириллический
]
и так далие.
Так вот я заметил что если стоит самый последний шрифт Arial кириллический кириллический...кириллический]
то при редактирования такой зоны AC сразу вылетает приходиться в ручную ставить Arial чтобы можно было отредактировать зону. Это очень утомительно и отнимает много времени.
Пробывал ставить любой другой шрифт аналогичная картина автоматом создаёт
Tahoma
[Tahoma кириллический]
[Tahoma кириллический кириллический]
[Tahoma кириллический кириллический кириллический]

Итакже глючит.
Работал в АС 9 (1812 - 2219 RUS и Eng) во всех такая картина.
Как избавиться от такого глюка чтобы можно было работать с зонами?

*

Оффлайн crazyASD

  • Самый главный
  • *****
  • 8376
  • Репутация: +506/-24
  • Пол: Мужской
  • iCrazy
Re: Проблемы с зонами в АС9
« Ответ #9 : Апреля 20, 2006, 02:20:22 »
На сайте ArchiCAD.ру уже около года лежит вот это чудо, после него лично у меня зоны заработали без проблем! :)
Забираем  http://cadstudio.ru/uploaded/files/gost9.rar
Да! и естественно это надо распаковать в папку Библиотека ArchiCAD 9
« Последнее редактирование: Декабря 11, 2007, 21:47:58 от Valery W »

*

archiDAN

Re: Проблемы с зонами в АС9
« Ответ #10 : Апреля 21, 2006, 20:29:09 »
Под руководством nideKer была найдена причина из за чего при работе с зонами глючил АС9 (2219) RUS .
Вот какие настрой в реестре должны стоять.
Если запущен АС то закройте его.
Откройте ветку реестра HKEY_CURRENT_USER/Software/Graphisoft/ArchiCAD/ArchiCAD 9.0.0 RUS R1/Font Description
Сверить:
Font Script Code = 0
HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/Nls/CodePage
Сверить:
"1250"="С_1251.nls"
"1252"="С_1251.nls"
Запустите АС, откройте Параметры зоны по умолчанию > Паспорт зон и поставьте в свойствах шрифта Западный. Не ставте ни в коем случае Кириллический, так как он начнет размножаться и зоны начнут глючить снова.

« Последнее редактирование: Апреля 28, 2008, 11:09:51 от Valery W »

*

mizarra

Re: Проблемы с зонами в АС9
« Ответ #11 : Сентября 24, 2006, 13:18:47 »
Кстати, Font Script Code... ставим 204 для 8. и 516 для 9-й версии. И ветку грабить не нужно. Для ветки хорош XP Twеаker, в нём эта функция прописана.

 

Похожие темы

  Тема / Автор